use strict;
my $str = '1,A,"apple"
2,B,"banana"
3,C,"cherry
4,D,"durian"
5,E,"elderberry
6,F,"Fanta™"
7,G,"grape
8,H,"honeydew"';
my $regex = qr/[^"]$/mp;
my $subst = '$0"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";