// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[^"]$"#).unwrap();
let string = "1,A,\"apple\"
2,B,\"banana\"
3,C,\"cherry
4,D,\"durian\"
5,E,\"elderberry
6,F,\"Fanta™\"
7,G,\"grape
8,H,\"honeydew\"";
let substitution = "$0\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}