const regex = /[^"]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^"]$', 'gm')
const str = `1,A,"apple"
2,B,"banana"
3,C,"cherry
4,D,"durian"
5,E,"elderberry
6,F,"Fanta™"
7,G,"grape
8,H,"honeydew"`;
const subst = `$0"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);