package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^"]$`)
var str = `1,A,"apple"
2,B,"banana"
3,C,"cherry
4,D,"durian"
5,E,"elderberry
6,F,"Fanta™"
7,G,"grape
8,H,"honeydew"`
var substitution = "$0""
fmt.Println(re.ReplaceAllString(str, substitution))
}