using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^""]$";
string substitution = @"$0""";
string input = @"1,A,""apple""
2,B,""banana""
3,C,""cherry
4,D,""durian""
5,E,""elderberry
6,F,""Fanta™""
7,G,""grape
8,H,""honeydew""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}