# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$\d+(?:,\d+)*\.\d{2}\b/"$0"/gm;t' <<< "abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc
"