$re = '/\$\d+(?:,\d+)*\.\d{2}\b/m';
$str = 'abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc
';
$subst = "\"$0\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;