package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\d+(?:,\d+)*\.\d{2}\b`)
var str = `abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc
`
var substitution = ""$0""
fmt.Println(re.ReplaceAllString(str, substitution))
}