# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$\d+(?:,\d+)*\.\d{2}\b"
test_str = ("abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc\n")
subst = "\"$0\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.