re = /\$\d+(?:,\d+)*\.\d{2}\b/m
str = 'abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc
'
subst = '"$0"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result