const regex = /\$\d+(?:,\d+)*\.\d{2}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\d+(?:,\\d+)*\\.\\d{2}\\b', 'gm')
const str = `abc,dec,\$123,34.00,abc abc,dec,\$123,34,56.00,abc
`;
const subst = `"$0"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);