import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\d+(?:,\\d+)*\\.\\d{2}\\b";
final String string = "abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc\n";
final String subst = "\"$0\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}