import Foundation
let pattern = #"\$\d+(?:,\d+)*\.\d{2}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$0""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)