using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\d+(?:,\d+)*\.\d{2}\b";
string substitution = @"""$0""";
string input = @"abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}