use strict;
my $str = 'abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc
';
my $regex = qr/\$\d+(?:,\d+)*\.\d{2}\b/mp;
my $subst = '"$0"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";