# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([E]\d{5}-\d{2})/<a href="http:\/\/somepage.com?number=$1">$1<\/a>/g;t' <<< "Like E12345-01 does not be"