using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([E]\d{5}-\d{2})";
string substitution = @"<a href=""http://somepage.com?number=$1"">$1</a>";
string input = @"Like E12345-01 does not be";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}