package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([E]\d{5}-\d{2})`)
var str = `Like E12345-01 does not be`
var substitution = "<a href="http://somepage.com?number=$1">$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}