import re
regex = re.compile(r"([E]\d{5}-\d{2})")
test_str = "Like E12345-01 does not be"
subst = "<a href=\"http://somepage.com?number=$1\">$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)