use strict;
my $str = 'Like E12345-01 does not be';
my $regex = qr/([E]\d{5}-\d{2})/p;
my $subst = '<a href="http://somepage.com?number=$1">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";