$re = '/([E]\d{5}-\d{2})/';
$str = 'Like E12345-01 does not be';
$subst = "<a href=\"http://somepage.com?number=$1\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;