const regex = /([E]\d{5}-\d{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([E]\\d{5}-\\d{2})', 'g')
const str = `Like E12345-01 does not be`;
const subst = `<a href="http://somepage.com?number=$1">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);