re = /([E]\d{5}-\d{2})/
str = 'Like E12345-01 does not be'
subst = '<a href="http://somepage.com?number=$1">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result