import Foundation
let pattern = #"([E]\d{5}-\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Like E12345-01 does not be"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="http://somepage.com?number=$1">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)