# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/href="([^#]*?)(#[^"]*?)"/href="$1"/gm;t' <<< "<a href=\"/#abc\">test</a>
<a href=\"#def\">test2</a>
<a href=\"/index.php?a=1#feg\">test3</a>
<a href=\"/test.php?c=2\">test4</a>
<a href=\"/test\">test5</a>
"