const regex = /href="([^#]*?)(#[^"]*?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="([^#]*?)(#[^"]*?)"', 'gm')
const str = `<a href="/#abc">test</a>
<a href="#def">test2</a>
<a href="/index.php?a=1#feg">test3</a>
<a href="/test.php?c=2">test4</a>
<a href="/test">test5</a>
`;
const subst = `href="$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);