$re = '/href="([^#]*?)(#[^"]*?)"/m';
$str = '<a href="/#abc">test</a>
<a href="#def">test2</a>
<a href="/index.php?a=1#feg">test3</a>
<a href="/test.php?c=2">test4</a>
<a href="/test">test5</a>
';
$subst = "href=\"$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;