# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"href=\"([^#]*?)(#[^\"]*?)\""
test_str = ("<a href=\"/#abc\">test</a>\n"
"<a href=\"#def\">test2</a>\n"
"<a href=\"/index.php?a=1#feg\">test3</a>\n"
"<a href=\"/test.php?c=2\">test4</a>\n"
"<a href=\"/test\">test5</a>\n\n")
subst = "href=\"$1\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.