using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""([^#]*?)(#[^""]*?)""";
string substitution = @"href=""$1""";
string input = @"<a href=""/#abc"">test</a>
<a href=""#def"">test2</a>
<a href=""/index.php?a=1#feg"">test3</a>
<a href=""/test.php?c=2"">test4</a>
<a href=""/test"">test5</a>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}