import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"([^#]*?)(#[^\"]*?)\"";
final String string = "<a href=\"/#abc\">test</a>\n"
+ "<a href=\"#def\">test2</a>\n"
+ "<a href=\"/index.php?a=1#feg\">test3</a>\n"
+ "<a href=\"/test.php?c=2\">test4</a>\n"
+ "<a href=\"/test\">test5</a>\n\n";
final String subst = "href=\"$1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}