re = /href="([^#]*?)(#[^"]*?)"/m
str = '<a href="/#abc">test</a>
<a href="#def">test2</a>
<a href="/index.php?a=1#feg">test3</a>
<a href="/test.php?c=2">test4</a>
<a href="/test">test5</a>
'
subst = 'href="$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result