import Foundation
let pattern = ##"href="([^#]*?)(#[^"]*?)""##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<a href="/#abc">test</a>
<a href="#def">test2</a>
<a href="/index.php?a=1#feg">test3</a>
<a href="/test.php?c=2">test4</a>
<a href="/test">test5</a>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"href="$1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)