#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)href="([^#]*?)(#[^"]*?)""
Local $sString = "<a href="/#abc">test</a>" & @CRLF & _
"<a href="#def">test2</a>" & @CRLF & _
"<a href="/index.php?a=1#feg">test3</a>" & @CRLF & _
"<a href="/test.php?c=2">test4</a>" & @CRLF & _
"<a href="/test">test5</a>" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "href="$1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)