// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href="([^#]*?)(#[^"]*?)""#).unwrap();
let string = "<a href=\"/#abc\">test</a>
<a href=\"#def\">test2</a>
<a href=\"/index.php?a=1#feg\">test3</a>
<a href=\"/test.php?c=2\">test4</a>
<a href=\"/test\">test5</a>
";
let substitution = "href=\"$1\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}