#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\s\S]*?)(football)"
Local $sString = "Here is football match.\n I want to replace football with something else \n that also consider to change footballA too"
Local $sSubst = "\1boxing"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)