re = /([\s\S]*?)(football)/m
str = 'Here is football match.\\n I want to replace football with something else \\n that also consider to change footballA too'
subst = '\\1boxing'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result