package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s\S]*?)(football)`)
var str = `Here is football match.\n I want to replace football with something else \n that also consider to change footballA too`
var substitution = "\1boxing"
fmt.Println(re.ReplaceAllString(str, substitution))
}