import re
regex = re.compile(r"([\s\S]*?)(football)", flags=re.MULTILINE)
test_str = "Here is football match.\\n I want to replace football with something else \\n that also consider to change footballA too"
subst = "\\1boxing"
result = regex.sub(subst, test_str)
if result:
print(result)