const regex = /([\s\S]*?)(football)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\S]*?)(football)', 'gm')
const str = `Here is football match.\\n I want to replace football with something else \\n that also consider to change footballA too`;
const subst = `\1boxing`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);