using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\s\S]*?)(football)";
string substitution = @"\1boxing";
string input = @"Here is football match.\n I want to replace football with something else \n that also consider to change footballA too";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}