# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[title(\s.*?)?](.*?)\[\/title]/[new_title$1 title="$2"]/gis;t' <<< "[title type=\"1\"]Test[/title] [title]Test2[/title]
[title type=\"6\"]Test With
Newline 3[/title]"