$re = '~\[title(\s.*?)?](.*?)\[/title]~is';
$str = '[title type="1"]Test[/title] [title]Test2[/title]
[title type="6"]Test With
Newline 3[/title]';
$subst = "[new_title$1 title=\"$2\"]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;