#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?is)\[title(\s.*?)?](.*?)\[/title]"
Local $sString = "[title type="1"]Test[/title] [title]Test2[/title]" & @CRLF & _
" [title type="6"]Test With" & @CRLF & _
"Newline 3[/title]"
Local $sSubst = "[new_title$1 title="$2"]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)