use strict;
my $str = '[title type="1"]Test[/title] [title]Test2[/title]
[title type="6"]Test With
Newline 3[/title]';
my $regex = qr~\[title(\s.*?)?](.*?)\[/title]~isp;
my $subst = '[new_title$1 title="$2"]';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";