package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)\[title(\s.*?)?](.*?)\[/title]`)
var str = `[title type="1"]Test[/title] [title]Test2[/title]
[title type="6"]Test With
Newline 3[/title]`
var substitution = "[new_title$1 title="$2"]"
fmt.Println(re.ReplaceAllString(str, substitution))
}