# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[title(\s.*?)?](.*?)\[/title]"
test_str = ("[title type=\"1\"]Test[/title] [title]Test2[/title]\n"
" [title type=\"6\"]Test With\n"
"Newline 3[/title]")
subst = "[new_title$1 title=\"$2\"]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.