using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[title(\s.*?)?](.*?)\[/title]";
string substitution = @"[new_title$1 title=""$2""]";
string input = @"[title type=""1""]Test[/title] [title]Test2[/title]
[title type=""6""]Test With
Newline 3[/title]";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}