import Foundation
let pattern = #"\[title(\s.*?)?](.*?)\[/title]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
[title type="1"]Test[/title] [title]Test2[/title]
[title type="6"]Test With
Newline 3[/title]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[new_title$1 title="$2"]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)