import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[title(\\s.*?)?](.*?)\\[/title]";
final String string = "[title type=\"1\"]Test[/title] [title]Test2[/title]\n"
+ " [title type=\"6\"]Test With\n"
+ "Newline 3[/title]";
final String subst = "[new_title$1 title=\"$2\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}