re = /\[title(\s.*?)?](.*?)\[\/title]/i
str = '[title type="1"]Test[/title] [title]Test2[/title]
[title type="6"]Test With
Newline 3[/title]'
subst = '[new_title$1 title="$2"]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result